[SATLUG] SATLUG RE:strange grub action on X64x2 MB solved

gboswell gboswell at cis.sac.accd.edu
Thu Dec 27 13:52:57 CST 2007


> Anyone have a problem with grub on a x64x2 MB? I upgraded from a amd 
> 2200/MB to a Amd 4400/ 64x2 MB with mostly same hardware installed.
>
> I have 4 ide drives (2 DVD/RW) and two ide (40g, 250g).  I have grub  
> in  hd0  (really  /dev/hda  but  when  I rescue  FC7/ or FC8 (64bit)  
> it  says it is /dev/sda) . Linux is in the hd1,4 at 155MB location on 
> hdb.  Now the error  grub gives is  18  which leads me to believe  
> that the  boot  drives  (for linux and grub.conf) are out of range for 
> the bios. Problem is on the AMD2200/i386 MB the same drives and 
> partitions worked great.
>
> The problem surfaced when I installed/upgraded FC8 64Bit to replace 
> the FC7. The only diff is the orginal FC7 was LogVol default where as 
> I wanted to custom the partion sizes to /boot 100M swap 2000M /40000M 
> and /home 44000M with the new MB.
>
> (In truth I never  booted  the old system with the  new MB  but went 
> directly  to installing/upgrade  FC8 64Bit  in the  old Linux  
> partition area, I know  violation of rule #one, only change one thing 
> at a time)
>
> What am I missing?
>
> Thanks Boz
Scme how just moving partitions around so I could get a /boot in first 
40G solved the problem. Is there a limit with grub on how far can 
stretch to find stage1 & 2. Not in info grub nor in google, well at 
least where I searched.

Thanks Boz

-- 
Glenn Boswell "Boz"      gboswell at cis.sac.accd.edu
Note the address above as gboswell at accd.edu dies 12/22/07
Personal email should be directed to gboswellsac at yahoo.com
San Antonio College  Dept. CIS (210)-733-2866

"Freedom is not FREE", let us never forget.

"We make a living by what we Get.
 We make a LIFE by what we GIVE." anonymous



More information about the SATLUG mailing list