[SATLUG] Undelete-able files...

herb cee hc at lookcee.com
Thu Apr 17 21:55:22 CDT 2008


Wayne Walker wrote:
> mkdir foo
> touch foo/bar
> chmod 555 foo
> rm foo/bar
>
> On Sun, Apr 06, 2008 at 12:47:41AM -0500, John Pappas wrote:
>   
>> Hey All,
>>
>> I have run into an odd issue.  Is there a way a user could create
>> files/directories that they then cannot delete?  Extended ACLs are not
>> enabled (AFAICT) and user.group are correct for said user, and permissions
>> are 777.
>>     
>
Hope you guys don't mind my posing my mystery into your dialog. I would 
love to understand the above Command syntax, I really don't see what you 
did, I am gonna try tho.

My mystery is on a 1 gig SanDisk Flash card, (formated fat-16) I created 
a folder from a Ubuntu 8.10 and wound up with a frozen card. It refuses 
to delete any files at all on the disk giving various error messages 
when I answer the dialog asking if I want to *empty the trash* either 
way I answer it refuses to dump and to dismount and if I pull power and 
reattach the reader the card is unchanged. I can access the files and 
move them, delete them and it all works fine but no way to unmount the 
drive and the card is restored somehow. Since I did successfully 
transfer all the 100mbs off to the HD I tried to format the card both on 
the puter and on the camera that uses the Fat-16 for .jpg.  After that 
the card no longer worked in the Camera but still reads same frozen 
picture. I have not had a response from SD tech.

I just wondered if this was related? If not I apologise.
herb




More information about the SATLUG mailing list