[SATLUG] Firefly 4 GB Flashdrive - unreadable

Stephen Gutknecht (RoundSparrow) stephen at roundsparrow.com
Fri Apr 18 07:48:32 CDT 2008


Kind of a long rambling observation; mostly theory as I I've had the same
experience about a dozen times over the past 3 years.

Flash drives just seem fragile to me in how you use them. I've had 2GB SD
that works perfectly fine in a digital camera a dozen times - pop it into a
computer and try to use for an OS project - and it corrupts or goes bad.
Both USB Flash and SD Cards have done this to me, even reputable brands like
Kingston and Lexar.

Putting a 'defunct' SD card back into a diigital camera and it won't format
-  I conclude something got corrupt.

And I'm not talking any abusive (heavy writing) behavior such as putting
swap files or heavy writes.  it is more like they are fragile in what file
system they expect or even unexpected repartitioning causes them grief.
>From what I understand, some of these flash have a buffer/cache area so they
are fast for a smaller amount of space.  Maybe it is this logic or the level
wearing?  It almost seems like these things have firmware in them and it is
just buggy in some assumptions it makes.  Many have flashing LEDs to show
activity and similar features - so maybe it is indeed firmware issues.

Anyway - I've had it happen.  I've seen some utilities that are supposed to
low level format - but I've never seem to be able to recover one once it
corrupts. I either exchange them or toss them away.  And it seems very model
speciifc.  A Lexar 1GB I get 6 month earlier works fine, but some newer
model 2GB corrupts on the first few uses to try and do OpenBSD or Linux.
Very frustrating.

SanDisk is supposed to be one of the better ones for 'sophisticated PC
usage' in terms of their firmware.  But I had it happen on a 1GB SanDisk SD
card I tried a couple weeks ago.  I've just gotten kind of gun shy about
trying to use flash for anything that needs to alter the format or
partitions - as they just give you grief.

My conclusion:  Many of these devices have buggy firmware that makes a lot
of incorrect assumptions about the format/filenames/layout/directory
structure of the disk - and they just crash internally if something gets on
them that they don't expect.  And I've found no way to 'reset them' once
this happens - as the crash in such a way that you can't even get their
firmware to allow writing/format.

  Stephen Gutknecht
  South Austin and Canyon Lake
  http://twitter.com/RoundSparrow



On Fri, Apr 18, 2008 at 12:52 AM, John Chalinder <argiod at bresnan.net> wrote:

> I have a Lexar Firefly 4GB flash drive that, while 'properties' tells me
> it's ok, and my laptop recognises what sort of a drive it is, it will not
> respond to any action.
>  I've tried formatting, I've tried ejecting, I've tried checking for
> errors. Nada, zip, zero response. Can't even change its name.
>
> Any idea what could be wrong with this device, and how/if it can be fixed?
> It cost me around $60 and it's been too long to take it back to the store
> and refund/exchange it.
>
> Maybe it doesn't like Ubuntu Linux formatting...? Maybe it doesn't like to
> be reformatted at all.
>


More information about the SATLUG mailing list