[SATLUG] Java problem on Ubuntu 8.04 beta

Ryan Stewart rds6235 at gmail.com
Thu Apr 24 07:41:24 CDT 2008


Greetings all. I've been lurking here a while, and I've got a question now.
First, I'm fairly new to Linux. I can find my way around the command line,
but I don't know too much about Linux overall.

I downloaded the desktop version of ubuntu 8.04 beta, and I tried running it
on one box as a LiveCD. I downloaded the self-extracting Java installer,
version 1.6 update 5, made it executable, and ran it in /opt. It extracts to
a directory /opt/jre1.6.0_05. When I run /opt/jre1.6.0_05/bin/java -version,
I get an error message similar to this (don't have the exact message on
hand):

"error while loading shared libraries: libjli.so: cannot open shared object
file: No such file or directory"

I've done exactly the same thing with the same ubuntu version installed in a
VMware VM, and it works fine.

The file libjli.so exists in /opt/jre1.6.0_05/lib/i386/jli. I found that if
I copy this file to /usr/lib, it no longer complains about it, but instead
says it can't find libjava.so, which exists in /opt/jre1.6.0_05/lib/i386.
Copying that file to /usr/lib doesn't help.

Tonight I'm going to try installing ubuntu to a hard drive on the computer
that's having the problem and see what happens, but I'm still curious what
would cause this. Does anyone have any suggestions?


More information about the SATLUG mailing list