[SATLUG] Firefox 3.0.1 issue

Geoff geofff at w5omr.shacknet.nu
Sun Aug 24 10:02:38 CDT 2008


Justin Burdette wrote:
> I'm having a strange problem...Firefox will crash randomly and not load
> again until I reboot. When I click the icon (or try to run it in any way
> from CLI), KDE System Guard shows 2 Firefox processes, but it does
> absolutely nothing.
>
> I've tried clearing my cache, disabling my extensions, and nothing has
> worked so far. The only way to get it to come up is to reboot the machine.
> (Restarting X doesn't work either...)
>
> Anyone else having this problem, or have any ideas?
>   

This is an old thread, I know, but I finally found some time and go
through the backlog of mail.

When an application crashes, sometimes the pid is still active.  If you
were to do a 'ps -ef | grep -i firefox' you will probably find that
something is keeping firefox from closing.  If you just kill the pid,
(kill ${pid_number}) then recheck with the aforementioned ps command and
it's -still- there, then go with the 'kill -s 9 ${pid_number} command.

for example, I log in to my system via remote and I log off the session
(disconnect vs terminate) then re-log on as another user, and try to
look at the mail via thunderbird, I won't be able to because the
application is already running.

So, how do I kill it?

First I need to find out what it's pid is (process Identification, if I
recall correctly)

> ps -ef | grep -i thunderbird
w5omr     6423     1  0 Aug19 ?        00:00:00 /bin/sh /usr/bin/thunderbird
w5omr     6425  6423  0 Aug19 ?        00:07:36
/usr/lib/thunderbird/thunderbird-bin
root     14281 11631  0 09:56 pts/0    00:00:00 grep -i thunderbird

Ah, ok.  the thunderbird binary is still active.  I want to kill it.

> kill 6425

if I run ps -ef | grep -i thunderbird again, and the simple kill command
didn't work, then I issue the;

kill -s 9 6425

9 times out of 10, that -will- kill the process.

Hope that helps.  Anyone else can feel free to correct me.

--
-Geoff



More information about the SATLUG mailing list