[SATLUG] Printing Mystery Might be OT .

herb cee hc at lookcee.com
Tue Dec 23 14:17:25 CST 2008


 My first ? is why did the printer command reboot my entire machine. 
Second if I duplicate this failure where do I look for clues about why 
the failure panicked the OS?? What CLI code do I use? I apologize for 
the verbosity but it's a full story and why I can't do much with Google. 
I hope at least the story is interesting.

The rig is a P-4 with AMD 1.8CPU, 1.4G-SDRAM266 80G HD Printer is 
Brother-2140 Laser, near new. OS is Server Ubuntu 8.04 fully updated 
using CUPS and the driver was automatically installed when the printer 
was detected by the sys USB, Has printed perfectly with no prior problems.

Background here is my friend/neighbor and I share research interest in 
sustainable farming and her Win-XP got zapped and so she asked if i 
would copy my file for her since I have a portable 60G HD on a USB box 
so I copied all the manuals/.pdf files and took it to her and they 
loaded off fine. So she tried to load a new E-book she acquired from the 
CD to my HD but it refused to copy, no complaint just ignoring the copy 
command ala-Windows, anyway, I said I would just copy directly from the 
disk and return it. That worked fine and I don't recall any problem at 
the time, the file is sitting on this rig now. I returned the CD. My 
friend knew that I had just bought the new Laser printer and ask if I 
would print the book for her and she would pay for paper and ink. The 
following error sequence and my wriggles occurred.

This book title is "The Complete Book of Self-Sufficiency" it's filled 
with illustrations on a .PDF file so I opened it with Ubuntu 8.04 
Document Viewer and since book is 258 8x11 pages decided to print it on 
both side of the paper. I ran the even pages first and it printed all 
the pages great.

I let the paper cool for a bit then fed the stack back in for the odd 
pages and was fine until I got a paper jam at pg 247 so final good page 
was 246. so all I needed was to redo those final 6 sheets I removed the 
jam printed a test page and reset the print to print just the evens and 
clicked print and got a OS crash. Total reboot.

Now thinking I had just printed OK test page ??? I tried printing from 
another file worked fine 100%, then selected single pg from the book, 
got booted. I remembered reading where someone had put a copy-write 
program embedded into the CD that punished somewhat like that, and that 
the workroun was to copy the file giving it a new name.

So I copied to diff dir and selected the 6 even pages and voila it 
printed them but when I turned the stack over to print odd 6 it printed 
1 sheet and stopped and when I tried to restart printing, got booted. I 
renamed the file asked again for single pg., got booted.

LOL ... I gave the slightly short book to my friend but I do want to 
retry to print those missing pages and to capture why the sys boot is 
happening. Can someone please guide me in my effort? I am ready to copy 
the .PDF to a diff directory and I am sure it will allow me to print the 
entire file but I will choose just the final pages and then the failure 
will occur when I try to print the reverse sides.

Thanks,
herb



More information about the SATLUG mailing list