[SATLUG] Wireless Driver Installation

John Pappas j at jvpappas.net
Sun Jul 20 17:01:22 CDT 2008


Sorry, this has been a "draft" as I kept getting distracted.  Anyway:

On Fri, Jul 18, 2008 at 17:26, Andrew Pickens <wg5o at sbcglobal.net> wrote:

>
> Here it is, but no wlan0, yet:
>
> andy at izzy:~$ sudo ndiswrapper -l
> [sudo] password for andy: mrv8335 : driver installed
>        device (11AB:1FAA) present
> net8185 : driver installed
>

At least ndiswrapper thinks it is working like it should.


> andy at izzy:~$ sudo depmod -a
> andy at izzy:~$ sudo modprobe -r ndiswrapper
> andy at izzy:~$ sudo modprobe ndiswrapper
> andy at izzy:~$ sudo tail -n20 /var/log/messages
> Jul 18 17:14:07 izzy kernel: [ 4059.466396] usbcore: deregistering
> interface driver ndiswrapper
> Jul 18 17:14:07 izzy kernel: [ 4059.468389] ndiswrapper
> (ntoskernel_exit:2708): object ffff810039c65230(2) was not freed, freeing it
> now
> Jul 18 17:15:27 izzy kernel: [ 4139.773084] ndiswrapper version 1.52 loaded
> (smp=yes, preempt=no)
> Jul 18 17:15:27 izzy loadndisdriver: loadndisdriver: load_driver(358):
> couldn't load driver mrv8335

Jul 18 17:15:27 izzy kernel: [ 4139.874982] usbcore: registered new
> interface driver ndiswrapper


I guess I should have had you run an `ndiswrapper -l` listing after the
reload, as the 2nd to last line above indicates that the module did not load
the driver, thus the hardware would not show up.

I would try removing the mrv8335 driver from ndiswrapper, unloading the
kernel module, re-installing driver in ndiswrapper, verify proper driver
load in /var/log/messages and `ndiswrapper -l`, and see if the hardware
appears.

HTH,
John


More information about the SATLUG mailing list