[SATLUG] reisersfs vs other file systems

Geoff geofff at w5omr.shacknet.nu
Tue Jul 22 08:22:30 CDT 2008


Ok.  The deal is, I wanted to take the big 160gig drive out of my XP
box, and shove it into the Compaq dual PIII 733MHz server, with an above
board promise IDE controller card.

I have, on the main ide controller buss(ide0) a WD 30gig, and a WD 80gig.
On ide1, there's a WD 80gig and a DVD/RW drive.

All have 80pin cables.  All PATA IDE.  No SATA.

On the promise controller, there's another WD 80gig drive and the
Hitachi (I think) 160gig drive.

After all the files had been moved off of the 160gig drive, while it
lived it's live in Hell, er... I mean 'the Windows environment', (;->)
that box was downed, the drive removed, put on the 80pin cable on the
promis controller card, jumpers set as they were, as master, with a
slave present.  The 80gig drive set to be the slave, and booting the
server all 4 drives are seen.  All is good.

Using the 2.6.22.13-0.3 kernel in openSuSE 10.3, the drives are labled as
sda, sdb, sdc, hda, and hdb.  the hd drives, are those that are on the
above-board controller.

So, I ran fdisk /dev/hda, removed the partition, created a partition,
primary partition, and only 1, went to write the partition table, and
the system locked up.  Rebooted, got back into fdisk, did everything
again, and all worked.  Created a primary partition, using the defaults,
then ran
mkfs.xfs /dev/hda1
only to have /dev/hda1 spit out errors like -crazy- to
/var/log/messages, mostly dma messages.  Hmmm... drive going bad?  No...
it's been running without failure for what seems like eons in the
{{{shudder}}} winders box {*~whew~*} so I thought to my self... hmmm...

re-ran fdisk, deleted that partition, created a new partition, and then
formatted it with reisersfs.  Since then, I've not seen any errors.

is there something wrong with the xfs file system?  is ext3 the better
way to go?  I know there's no more support for reisersfs, but that's the
fs I've had the most luck with.  Is it because of the journaling?  Could
the drive itself be going bad?  Is it the controller card?  There's no
issues with the 80gig harddrive that's on it, running xfs.

Thoughts?

(I'm really looking for hardware support input from the likes of Tom
Weeks, Brad, Jeremy Mann, Jennifer, Ed Coates...) and -please- don't
quote the entire message back to me.  I typed it, it's been read by
everyone, and we don't -need- to see 'all' of it, again.. just pertinent
quotes.  Intersperse comments throughout the text... no top posting...
'please'.

-Geoff



More information about the SATLUG mailing list