[SATLUG] Drive ID Change (sdx vs hdx)

herb cee hc at lookcee.com
Wed Jun 18 20:40:08 CDT 2008


Daniel J. Givens wrote:
> libata is the new ATA driver that is supposed to phase out the
> previous drivers/ide. libata apparently uses the scsi layer, which
> causes the ATA devices to look like scsi devices. It looks like it was
> officially added to the kernel starting with 2.6.19[1] and distributions
> have been migrating to the new driver since. Ubuntu happened to be a
> big name leading the charge with 7.04 Feisty[2].
>
> [1] http://kernelnewbies.org/Linux_2_6_19
> [2] https://launchpad.net/ubuntu/+spec/libata-for-all-ata-disks
>
> I believe there were some issues in Feisty where you had systems get
> installed using the legacy ide driver. Following a kernel update at
> some point, some systems started using the libata driver without
> properly updating the hd[a-z] references in critical places causing
> some major breakage. I believe that was what happened on the server I
> mentioned in my other message. Additionally, there have been cases
> where the upgrade utilities failed to update the fstab and grub
> configuration to refer to the file systems by UUID, which caused
> problems to say the least. 
>
> At this point, the legacy ide driver is slowly being deprecated and
> libata is supporting more and more chipsets. I'm sure there will be
> older chipsets that never get support and will rely on the legacy ide
> driver, but most of the work done now seems to be focused on libata.
>
> An interesting comment made back in 2003 by J.A. Magallon about libata
> not using the scsi layer in 2.7[3]. Yeah, it's been a while and 2.7
> doesn't exist yet, but this just shows that it's best to stay as driver
> neutral as possible. Linus and crew have shown that they aren't afraid
> of making changes rapidly. 
>
> [3] http://www.kerneltraffic.org/kernel-traffic/kt20031004_233.html
>   

I suspect you are right Daniel. I had issues with my first 5.04 and 
fixed it with 6.10, then had issues involving hda and I fixed that with 
7.04, now when I tried to fix what I thought was an HD problem, finding 
that I had to change the command itself to 'sda'. .. <RANT><Incompetence 
in the workplace>

I just had not heard, nor did I suspect that in the OS auto-upgrades the 
most important name in the box got silently changed. My criticism is 
valid I believe. The OS knows why it failed, if they can change the 
device name they sure as hell should change the direction of an error 
code, I say a pox on lazyness, Yeah the change was free and auto-updated 
but that COST how many man-hours of user frustration in lost time? I 
spent over a day ... but then it's hard to be dumb! ... </RANT>

herb

..

In the dumbing down program of public education I used </Incompetence in 
the workplace> to point to the cause not the symptom. I also know that 
my only pol-power is being a member of AARP. I am totally ignored by 
both sides of the DuOpallyREPUB/DEM party. neither the bad guy nor good 
guy gives a crap.

herb






More information about the SATLUG mailing list