[SATLUG] Xscreensaver problem

John D Choate jdchoate at gmail.com
Thu Jun 26 10:59:14 CDT 2008


This isn't very important... I can do without screen savers, but I'm curious 
if anyone has seen this problem before.
It seems to be permissions related, but I can't figure why. I have installed 
my system several times on different machines and have installed and used 
xscreensaver-gl many times a well, without ever running into this (problem 
described a couple paragraphs below).

I recently upgraded my home computer, replacing the PSU, motherboard, CPU, 
RAM, drives and graphics card. I put all of the old parts on a shelf for a 
few weeks until I got a new case and put all of that into it.
The only difference is that I put my old sound card in the new machine and 
enabled the onboard sound for my older system.
I did a clean installation (Mandriva 2008.1) onto the old drive, formatting 
the partitions except for /home. I have done this before with no problems and 
did nothing out of the ordinary this time. I have the same system running on 
2 other machines, all using the same ~/ for my user, copied from this 
original drive... all work properly.

Here's the problem... When I first tested 3D graphics, I did so with KDE's 
screensaver config utility which in turn makes use of xscreensaver-gl. The 
first run of a 3d screen saver would run fine, but upon exiting the screen 
saver, system performance would come to a near-halt... even the mouse cursor 
got slow and jerky. I would have to restart X to get back to normal.
I then tried using xscreensaver-demo to test them directly. Xscreensaver would 
display an error... I can't remember the wording (saying nothing about 
permissions)... and not run the screen saver at all. But performance would 
drop as well, causing me to CTRL-ALT-Backspace to restart X.

This problem does not happen if I startx as root and test the gl screensavers 
using KDE's screensaver configuration utility.
I tried deleting ~/.xscreensaver and letting it get recreated, but that did 
not help.

I know the nvidia driver works because 3D games work fine for my user, both 
natively and with wine.

What may have happened and what have I overlooked?


More information about the SATLUG mailing list