[SATLUG] Wireless paradox

ed horned0wl93 at gmail.com
Sun Mar 9 18:10:23 CDT 2008


gboswell wrote:
> At the computer show we had a lot of action and I believe helped a lot
> of people. I don't know how many cds were sold but all of the flyers
> and business cards were taken before 3pm. We had so many people the
> Owner asked if we were having a private convention. During the last 3
> hours the APCO (Alamo PC  group) rep. spent more time at our table
> than his own. Lot of the SATLUG regulars came by to help/pester
> everyone. I believe we all had a good time including Walt with a
> laptop who I believe had a running wireless Linux.
>
> During the show we had some interesting paradoxes with wireless cards.
> Eddie bought a new pcmcia "Atheros Chipset" which we set up madwifi
> module for. I had in another dell with a intel ipw3945 running native
> drivers for FC8. Nathan had a setup with Puppy Linux that worked somes
> times and some times not. Both Nathans and my Dells' 3945 work great
> with wireless elsewhere especially at SAC, during meetings. Another
> SATLUGer who teaches at Palo Alto College, who was a lot of help at
> the show, sorry bad at names, was running the bcmwl5 windows driver
> with ndiswrapper and was perfectly connected, as was my Macbook
> running osx. 
That's me -- Ed.  And I had the devil's own time configuring
iwconfig/ndiswrapper (Acer 3050 with Broadcom 4318 air card) under
Ubuntu 7.04, but it wraps neatly out of the box in Ubuntu 7.10.  Not
"native," by any stretch (Broadcom is still not forthcoming with it's
driver specs...), but close enough from what I see at home, and what I
got yesterday at UCCC/LCOO.  I get DHCP IP assignments quicker now under
Linux than I do with Windoze. 

My Dell Latitude D610  running Windoze Vista also hit the LCOO network
just fine, too, but much more slowly than did my Acer running Ubuntu 7.10.
> The paradox is his will not connect at SAC.  SAC uses a brandx
> wireless setup and the Universal City CC uses a cisco wireless access
> point.
Actually, I think I may have tumbled to the problem of logging in via
Linux/wireless at SAC, as I have the same exact problem at the Kelly
ATC:  there, I can login both wired and wireless under Windoze (XP), and
with a wire under Linux/Ubuntu, but NOT wirelessly.  At last month's
SATLUG meeting, I, and several other folk, had the same issues at SAC: 
wires worked ok, but wireless didn't.  I think it might have something
to do with the "Aruba Networks" login page we have to hit before getting
out to the web. I think, somewhere in there, there's a significant
conflict between its configuration and the way Linux/ndiswrapper handles
wireless communication.  -- just a thought...

The UCCC router looked, from a distance, like a LinkSys (Cisco) WTR54G,
similar to the one I have at home. I had about 54% signal strength for
most of the afternoon in both machines.  It'd be interesting to know,
precisely, how far away from the router our table was, and the router's
current firmware version.
>
> Now a big assumption that all were setup correctly, I know a BIG
> assumption but we checked the settings,  what  could be the  possible
> problems we should look into. BTW Windows worked perfectly on both
> Dells in UCCC and at SAC, and the Mac well it always works. The Dell
> e1405 is running FC8 with native ipw3945 intel drivers, The Dell C640
> running two different Atheros Pcmcia cards (Linksys and Airport101)
> with correct madwifi module loaded.  Both Dells see the cards as Wlan0
> but could not scan or find the LCOO-wireless network at the UCCC. The
> compaq with the bcmwl5 running ndiswrapper finds LCOO-wireless but not
> at SAC. Is it a driver/access point combination or just a quirk with
> each different setup. I believe Nathan was running Puppy Linux  on a 
> Compaq but I don't remember the  card  and/or  native/ndiswrapper setup.
Again, see my comments above:  Maybe one of us could ask the ACCD IT
Department for help in evaluating why there's such a disconnect with
Linux/ndiswrapper and their wireless network?  If both machines (my Acer
and the Compaq) running ndiswrapper work well in the LCOO network, but
not in ACCD's, then there's likely a problem with ACCD's access
controls.  That doesn't address why the ones that work within ACCD
couldn't see LCOO, but, its an approach...
> I'm looking for sources/settings to research and follow up on more
> than flame remarks. 
Agreed, in spades!
> It would be nice to have a set of procedures that would be fool proof
> if you have a supported chipset.
Is there a way to configure iwconfig/eth0 to work on different kinds of
networks?
> We sure  missed  Nate  Durr  being there to solve all our weird
> problems but Nate is a new Dad and is enjoying a new frontier. 
Congrats!
> This could be a birds of a feather session at the OpenFest but we need
> some real guidance as to some procedures. I've sucessfully set up
> ndiswrapper and  madwifi  following the  how-to's  and feel 
> competent  with ifconfig, iwconfig,  iwlist  etc.  Not being to get a
> good card to work with FC8 on a good machine with all the web
> resources at our disposal is frustrating. There must be some cutting
> edge ideas or procedures out there that can be applied in this kind of
> situation. The fact the ndiswrapper worked but doesn't work at SAC
> where the only difference is the access point or is there more to this
> story.
Every bit as curious as you are...  I should be able to make some of the
Open Source Fest, as I'm on Spring break that week.  I look forward to it.

Cheers!

Ed/the0wl



More information about the SATLUG mailing list