[SATLUG] wget frustration

Daniel Givens daniel at rugmonster.org
Fri May 23 06:33:15 CDT 2008

On Fri, May 23, 2008 at 4:59 AM, Geoff <geofff at w5omr.shacknet.nu> wrote:
> Ok, here's the deal.
> When I was in New Orleans, I got hooked on "Walton and Johnson" - a
> radio show in the mornings, played locally on Bayou 95 (95.7MHz).
> They're in different markets, as well.
> According to their affiliate list, their Houston home seems to be the
> only place to get their daily podcasts.  Without going through the
> rig-a-more-role of downloading each clip independently, I thought I'd
> just wget 'em all.  I have, in the past, figured out how to use a
> wildcard to get multiple files from a site, but for some reason the
> -A.mp3 (in this case) option doesnt' seem to be working.
> Here's the site
> http://www.the950.com/cc-common/podcast/single_podcast.html?podcast=mornings.xml
> here's the url to an .mp3 file
> http://a1135.g.akamai.net/f/1135/18227/1h/cchannel.download.akamai.com/18227/podcast/HOUSTON-TX/KPRC-AM/5.22.08-8A_4.mp3?CPROG=PCAST&MARKET=HOUSTON-TX&NG_FORMAT=talk&SITE_ID=676&STATION_ID=KPRC-AM&PCAST_AUTHOR=Walton_%26_Johnson&PCAST_CAT=Walton_%26_Johnson&PCAST_TITLE=Walton_and_Johnson
> Certainly I know that ever thing after the question mark is superfluous
> (as are big words) but the command of
> wget -A.mp3
> http://a1135.g.akamai.net/f/1135/18227/1h/cchannel.download.akamai.com/18227/podcast/HOUSTON-TX/KPRC-AM/
> didn't work, and I'm desperately trying to figure out why.

-A implies directory indexes are turned on. If you visit that URL, you
get a File Not Found error. wget doesn't have a list of available
files so it has nothing to base it's selections on.

More information about the SATLUG mailing list