[SATLUG] Hardware challenge, Part II

Alan Lesmerises alesmerises at satx.rr.com
Mon Aug 10 19:31:20 CDT 2009


Henry Pugsley wrote:
> You really don't want to dd the entire mbr or entire drive if the two
> drives are different sizes. The geometry will be different and you
> will end up with partitions that do not end on cylinder boundaries
> which can cause problems with future partition changes.
>
> If you dd the first 446 bytes of the MBR you will pick up the boot
> loader but not the partition table. Create the partitions separately
> and use the copy partition feature of GParted. This is the safest way
> to copy partitions to a larger or smaller drive.
>
> -Henry
>
> On 8/6/09, Tim <corpustexn at yahoo.com> wrote:
>   
>> --- On Thu, 8/6/09, Alan Lesmerises <alesmerises at satx.rr.com> wrote:
>>
>>     
>>> From: Alan Lesmerises <alesmerises at satx.rr.com>
>>> Subject: [SATLUG] Hardware challenge, Part II
>>> To: "SATLUG Mail Group" <satlug at satlug.org>
>>> Date: Thursday, August 6, 2009, 7:25 PM
>>> I've been working on the old Compaq
>>> system Art Hall had asked about cloning the old HD (from a
>>> few days ago), and I've run into an issue that I can't seem
>>> to find an answer for.
>>>
>>> I'm trying copy the boot files from the old drive to the
>>> new (in a terminal window running under a live CD version of
>>> GPartEd), and when I go to copy the files I need, I get an
>>> error "Cannot create regular file xxxxxxxx  Permission
>>> denied."
>>>
>>> I've made sure I was operating as root (su), that the
>>> drives were mounted as rw, and the rw permissions for the
>>> mount points are fully open (chmod 777).  I've tried
>>> changing permissions on the files themselves (they're
>>> -rw-------), but it won't let me.
>>>
>>> Does anyone recognize what's going on here and know what I
>>> can do to copy these files?
>>>
>>> TIA.
>>>
>>> Al Lesmerises
>>>
>>>       
>>   A few months ago I replaced the 160gig drive in my laptop with a 320 and
>> while my memory isn't what it should be, I think I did with something like
>> dd if=/dev/sda of=/dev/sdc bs=512. Now, that probably isn't exactly right.
>> And the result was my vista partition and several linux os's were copied
>> over byte for byte; and my 320 is now a 160.  Again a byte for byte.  I
>> switched drives, booted into one of the linux os's, and used gparted to
>> reclaim the other 160 gig.  You should be able to copy the mbr using a
>> similar dd command.  Just my 2 cents.
>>     
>>> -- _______________________________________________
>>> SATLUG mailing list
>>> SATLUG at satlug.org
>>> http://alamo.satlug.org/mailman/listinfo/satlug to
>>> manage/unsubscribe
>>> Powered by Rackspace (www.rackspace.com)
>>>       

Thanks, & I've basically tried doing just that with GPartEd (although I 
actually used a similar type of DOS program to copy the boot sector), 
but I still couldn't get the system to recognize the HD as bootable.  
Weird ...

Al Lesmerises



More information about the SATLUG mailing list