[SATLUG] Hardware challenge, Part II

Alan Lesmerises alesmerises at satx.rr.com
Mon Aug 10 19:39:44 CDT 2009


John Pappas wrote:
> On Fri, Aug 7, 2009 at 10:25, Alan Lesmerises <alesmerises at satx.rr.com>wrote:
>   
>> Tim wrote:
>>     
>>> --- On Thu, 8/6/09, Alan Lesmerises <alesmerises at satx.rr.com> wrote:
>>>       
>>>> From: Alan Lesmerises <alesmerises at satx.rr.com>
>>>> Subject: [SATLUG] Hardware challenge, Part II
>>>>
>>>> I'm trying copy the boot files from the old drive to the
>>>> new (in a terminal window running under a live CD version of
>>>> GPartEd), and when I go to copy the files I need, I get an
>>>> error "Cannot create regular file xxxxxxxx  Permission
>>>> denied."
>>>>         
> It is a bit unclear, but I assume that you are using one of the NTFS linux
> drivers (Assume ntfs-3g), and cp'ing between NTFS partitions (Both source
> and destination are NTFS partitions).
>
> The linux NTFS drivers have no way to respect the security (NTFS
> permissions) of the files, so I have not had a great amount of luck doing a
> `cp` for anything but a data recovery operation (Copy files from NTFS to
> other NATIVE linux FS).
>
> You may also want to try rsync, as that will both cut down on redundant copy
> attempts and (possibily) give more useful output than a failed cp.
>>>> I've made sure I was operating as root (su), that the
>>>> drives were mounted as rw, and the rw permissions for the
>>>> mount points are fully open (chmod 777).  I've tried
>>>> changing permissions on the files themselves (they're
>>>> -rw-------), but it won't let me.
>>>>         
> Suspect that the linux NTFS drivers are the cause.  You may want to try
> BartPE with robocopy (or xxcopy) to handle the windows to windows copy
> tasks, as the BartPE has access to the SAM and can properly respect
> permissions.
>
>> That may do the job, but it still doesn't answer the main question -- why
>> can't I copy those files?  What is it that cp doesn't like?
> Suspect the NTFS destination.
>
> HTH,
> jp
>   

Yes, I was trying to transfer data from one NTFS partitioned drive to 
another (from a 1.6GB to an 8.4GB drive).  And yes, that is I "was" 
trying -- I pretty much gave up on that attempt since I did have other 
tools to transfer the data.  The real problem was getting the new drive 
to be recognized as bootable, and copying the files was not the real 
obstacle there (just an attempt to try an alternate method to get from A 
to B).

I'm not familiar with rsync or BartPE, so I will check those out for the 
next time.  Thanks anyway.

Al Lesmerises



More information about the SATLUG mailing list