[SATLUG] First question - RAID5 quit working

David Labens adlabens at swbell.net
Sat Aug 15 19:43:54 CDT 2009

First, I apologize that I've been part of the group online since DECEMBER, and this is my first attempt to contact.  Life has been busy, but I'm not making excuses.

In December, I built a home server with an Asus motherboard & AMD 6400 processor & 4 gb RAM.  It's got an 80 gb HDD that is used exclusively for the OS (Linux Ubuntu 8.10 Server, running mostly headless unless boot-up visual is required, like right now), and 4 250 gb HDDs that are s/w configured as RAID5.

Everything has worked exceptionally well (built in December, not a glitch until 2 weeks ago), then, suddenly, I started getting errors trying to rename a folder.  I did a shut-down and reboot, and the RAID5 is no longer mounting.

Here's some current diagnostics:

root at RCH-SERVER:/boot/grub# cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
md0 : inactive sde1[0](S) sdc1[4](S) sdb1[2](S) sda1[1](S)
      976783360 blocks super 1.0

unused devices: <none>

And, I've tried:

root at RCH-SERVER:/home/admiral# mdadm --assemble --scan

				mdadm: /dev/md/0 assembled from 2 drives - not enough to start the array.

I KNOW that two brand new Western Digital HDDs did not go bad simultaneously, and really doubt that either of them went bad.  I read that it's a known problem that they get busied out by the OS, so I'm trying thinking this is the issue.

UNFORTUNATELY, I put off buying 1 tb drives for backup, and all our recipes, family pics, real estate, music, etc. is on there.  I have just received and installed one on in my Win XP Pro box, so I'm ready to do a first backup IMMEDIATELY upon getting the RAID5 array back working.

Any suggestions?  Any thoughts?  We're on a limited budget, but I'd be willing to pay someone who can make it work!


David Labens

San Antonio, TX

More information about the SATLUG mailing list