[SATLUG] First question - RAID5 quit working

David Labens adlabens at swbell.net
Sun Aug 16 08:32:03 CDT 2009

--- On Sat, 8/15/09, David Labens <adlabens at swbell.net> wrote:
> Date: Saturday, August 15, 2009, 7:43 PM
> First, I apologize that I've been
> part of the group online since DECEMBER, and this is my
> first attempt to contact.  Life has been busy, but I'm not
> making excuses.
> In December, I built a home server with an Asus motherboard
> & AMD 6400 processor & 4 gb RAM.  It's got an 80 gb
> HDD that is used exclusively for the OS (Linux Ubuntu 8.10
> Server, running mostly headless unless boot-up visual is
> required, like right now), and 4 250 gb HDDs that are s/w
> configured as RAID5.
> Everything has worked exceptionally well (built in
> December, not a glitch until 2 weeks ago), then, suddenly, I
> started getting errors trying to rename a folder.  I did a
> shut-down and reboot, and the RAID5 is no longer mounting.
> Here's some current diagnostics:
> root at RCH-SERVER:/boot/grub# cat /proc/mdstat
> Personalities : [linear] [multipath] [raid0] [raid1]
> [raid6] [raid5] [raid4] [raid10]
> md0 : inactive sde1[0](S) sdc1[4](S) sdb1[2](S) sda1[1](S)
>       976783360 blocks super 1.0
> unused devices: <none>
> And, I've tried:
> root at RCH-SERVER:/home/admiral# mdadm --assemble --scan
>     mdadm: /dev/md/0 assembled from 2 drives
> - not enough to start the array.
> I KNOW that two brand new Western Digital HDDs did not go
> bad simultaneously, and really doubt that either of them
> went bad.  I read that it's a known problem that they get
> busied out by the OS, so I'm trying thinking this is the
> issue.
> UNFORTUNATELY, I put off buying 1 tb drives for backup, and
> all our recipes, family pics, real estate, music, etc. is on
> there.  I have just received and installed one on in my Win
> XP Pro box, so I'm ready to do a first backup IMMEDIATELY
> upon getting the RAID5 array back working.
> Any suggestions?  Any thoughts?  We're on a limited
> budget, but I'd be willing to pay someone who can make it
> work!
> Thanks,
> David Labens
> San Antonio, TX

Tim responded with:

> --You have probably noticed the list gets quiet on weekends.  Unfortunately my experience with softraid is limited to raid0.  If nothing has changed with your setup I would definitely power off and recheck connections.  Another command if you haven't already tried.

> root at slack:/home/tim# mdadm --misc --detail /dev/md2 (enter)
        Version : 00.90.03
  Creation Time : Wed Aug 12 22:24:10 2009
     Raid Level : raid0
     Array Size : 111410560 (106.25 GiB 114.08 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 2
    Persistence : Superblock is persistent

    Update Time : Wed Aug 12 22:24:10 2009
          State : clean
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

     Chunk Size : 64K

           UUID : 2a29ef41:72ee10ea:e368bf24:bd0fce41
         Events : 0.1

    Number   Major   Minor   RaidDevice State
       0       8        8        0      active sync   /dev/sda8
       1       8       24        1      active sync   /dev/sdb8

>And if I wanted to mount one of my other os's also on raid0 assuming the array wasn't already assembled:

>mdadm --assemble /dev/md0 /dev/sda6 /dev/sdb6

>And then; mount -t jfs /dev/md0 /media/md0

>I know this probably doesn't help.  But since no one else is jumping in!

>Good luck.

Tim, Thank you for the response.  I'm VERY patient & understand that folks are attending other things over the weekends.

I ran:

root at RCH-SERVER:/home/admiral# mdadm --misc --detail /dev/md0

mdadm: md device /dev/md0 does not appear to be active.

So, I ran:

root at RCH-SERVER:/home/admiral# mdadm --assemble /dev/md0 /dev/sde1 /dev/sda1 /dev/sdb1 /dev/sdc1

mdadm: /dev/md0 assembled from 2 drives - not enough to start the array.

Which is the same result that I got with:

root at RCH-SERVER:/home/admiral# mdadm --assemble --scan

mdadm: /dev/md/0 assembled from 2 drives - not enough to start the array.

David Labens

San Antonio, TX

More information about the SATLUG mailing list