[SATLUG] First question - RAID5 quit working

David Labens adlabens at swbell.net
Sun Aug 16 23:18:12 CDT 2009



David Labens

San Antonio, TX

--- On Sun, 8/16/09, Samuel Leon <satlug at net153.net> wrote:

From: Samuel Leon <satlug at net153.net>
Subject: Re: [SATLUG] First question - RAID5 quit working
To: "The San Antonio Linux User's Group Mailing List" <satlug at satlug.org>
Date: Sunday, August 16, 2009, 3:24 PM

David Labens wrote:
> First, I apologize that I've been part of the group online since DECEMBER, and this is my first attempt to contact.  Life has been busy, but I'm not making excuses.
> 
> In December, I built a home server with an Asus motherboard & AMD 6400 processor & 4 gb RAM.  It's got an 80 gb HDD that is used exclusively for the OS (Linux Ubuntu 8.10 Server, running mostly headless unless boot-up visual is required, like right now), and 4 250 gb HDDs that are s/w configured as RAID5.
> 
> Everything has worked exceptionally well (built in December, not a glitch until 2 weeks ago), then, suddenly, I started getting errors trying to rename a folder.  I did a shut-down and reboot, and the RAID5 is no longer mounting.
> 
> Here's some current diagnostics:
> 
> root at RCH-SERVER:/boot/grub# cat /proc/mdstat
> Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10]
> md0 : inactive sde1[0](S) sdc1[4](S) sdb1[2](S) sda1[1](S)
>       976783360 blocks super 1.0
> 
> unused devices: <none>
> 
> And, I've tried:
> 
> root at RCH-SERVER:/home/admiral# mdadm --assemble --scan
> 

>                 mdadm: /dev/md/0 assembled from 2 drives - not enough to start the array.
>             
>         
> 
> I KNOW that two brand new Western Digital HDDs did not go bad simultaneously, and really doubt that either of them went bad.  I read that it's a known problem that they get busied out by the OS, so I'm trying thinking this is the issue.
> 
> UNFORTUNATELY, I put off buying 1 tb drives for backup, and all our recipes, family pics, real estate, music, etc. is on there.  I have just received and installed one on in my Win XP Pro box, so I'm ready to do a first backup IMMEDIATELY upon getting the RAID5 array back working.
> 
> Any suggestions?  Any thoughts?  We're on a limited budget, but I'd be willing to pay someone who can make it work!
> 
> Thanks,
> 
> David Labens
> 
> San Antonio, TX
> 

> Oh yuck. You are on pins and needles! If there is important 
> data on here then the first thing that I would do is pray! Then 
> spend the next hour (or maybe 2) reading the manual page: 
> http://man-wiki.net/index.php/8:mdadm
> You are going to have to force it to assemble.  Pretty much 
> the thing as this guy: http://www.linuxquestions.org/questions/linux-newbie-8/mdadm-question.-disk-failed-3-out-of-5.-742807/ 
> Do not make the mistake like this guy and think that restarting 
> the machine is going to magically fix anything.  In fact, I would 
> not restart the machine again until the array is fully rebuilt 
> and synced.
-------------------------------------
Unfortunately, that was the first thing I did (shut it down& reboot), and, when I realized I wanted to be ready to do an immediate backup upon getting the thing working again, I shut it down and left it off.  I figured there was no use in leaving it running for a week or two while waiting to receive a new HDD (just got a 1 tb drive from newegg on Friday, so I'm ready to backup now - it's in my WinXP box and formatted, ready to copy data over the network, as I figured that was the easiest and least "intrusive" backup until I have the thing working properly again) and then find GOOD help (like I have, here).
-------------------------------------
> So yes, step one, see if forcing will work:
> mdadm --assemble --scan -f

-------------------------------------
Ok, I tried this:
root at RCH-SERVER:/# mdadm --assemble --scan -f
& got this:
mdadm: forcing event count in /dev/sdc1(3) from 2978 upto 2986
Segmentation fault
-------------------------------------
> Also always make sure that email alerts are set up with 
> mdadm.  To check that email alerts are working do mdadm 
> --monitor --scan --test. This will send an email to the root 
> account on the server.  And on my server, all of root's emails 
> get sent to my main email account so I can keep an eye on 
> things...

-------------------------------------
When I run mdadm --monitor (& anything else), it goes into this mode where nothing I do gets a result.  It simply types what I type, and I can't seem to get it to exit.  So, I have to close the window (I use PuTTy from my WinXP box) and start over.  I definitely NEED to set it up to send email to me, but I'm not sure how to do this.
-------------------------------------
> Sam
-- _______________________________________________
SATLUG mailing list
SATLUG at satlug.org
http://alamo.satlug.org/mailman/listinfo/satlug to manage/unsubscribe
Powered by Rackspace (www.rackspace.com)


More information about the SATLUG mailing list