[SATLUG] RAID5 & ddrescue

David Labens adlabens at swbell.net
Sun Aug 23 09:56:52 CDT 2009


First, since none of the data drives were mounted, I shut down the server and removed all the data drives except /dev/sdc.  Then, I installed the new drive on the cable that had /dev/sda.  

Then, I ran fdisk and created a new primary partition.  Strangely enough, it would only allow me to create /dev/sda, not /dev/sdf that I WANTED to create, just to prevent confusion.  But, confusion had already set in.

Then, I went to use ddrescue:
ddrescue --no-split /dev/sdc /dev/sda logfile

Strangely enough, it quit after 80 gb was copied.  So, I examined the drives and found that /sdc was no longer the bad drive, but was now my 80 gb OS drive, and my bad drive was now /sdb (by examining & comparing serial numbers).  Fortunately, it had not turned the bad drive into /sda, so my bad data was still intact.

I tried rerunning the command, this time with the proper source drive, but it consistently started running it at the 80 gb point where the first command had stopped.  

So, I had to fdisk to remove the partition, write it to the system & exit, then run fdisk to create the partition & write it to the system & exit.

Here is the current output ...

root at RCH-SERVER:/# ddrescue --no-split /dev/sdb /dev/sda resclog1


Press Ctrl-C to interrupt
Initial status (read from logfile)
rescued:         0 B,  errsize:       0 B,  errors:       0
Current status
rescued:    17471 MB,  errsize:    233 kB,  current rate:   54525 kB/s
   ipos:    17471 MB,   errors:       4,    average rate:   52466 kB/s
   opos:    17471 MB
Copying data...

You can see that there are already 4 errors, but it's still working.

Updates will be forthcoming as progress is made.

But, I DO have a question...  When I go back to reassemble the array (after re-connecting everything), will the system automatically know which /sda is the copy of the /sdc that became the /sdb???

David Labens

San Antonio, TX


More information about the SATLUG mailing list