[SATLUG] RAID5 Recovery - ddrescue: copy completed!

David Labens adlabens at swbell.net
Sun Aug 23 13:08:28 CDT 2009


Every time I ran ddrescue, I gave it a different logfile name.  BUT, I don't think it uses the LOGFILE to figure out it's starting & stopping point.  I say this because when I figured out what I did wrong, and reran the command using a new logfile name, it still started copying from 80 gb!  That's when I figured I'd go in with fdisk and delete the partition & save it then recreate the partition.  I tried to do it without saving it (just delete partition & then recreate partition), and it still started from the 80 gb point.  But, when I saved it between, it started copying from the first byte to the last.  So, I'm confident that it did copy the full 250 gb from the source drive.

Would running the command again cause it to do nothing because it already ran?  Wouldn't I need to delete the partition & start over?  Or does the change in the command parameter allow it to retry and repair in the process?

David Labens

San Antonio, TX

--- On Sun, 8/23/09, Samuel Leon <satlug at net153.net> wrote:

From: Samuel Leon <satlug at net153.net>
Subject: Re: [SATLUG] RAID5 Recovery - ddrescue: copy completed!
To: "The San Antonio Linux User's Group Mailing List" <satlug at satlug.org>
Date: Sunday, August 23, 2009, 1:00 PM

David Labens wrote:
> ddrescue has completed, here's the command and resulting screen info:
> -------------------------------------------
> root at RCH-SERVER:/# ddrescue --no-split /dev/sdb /dev/sda resclog1
> Press Ctrl-C to interrupt
> Initial status (read from logfile)
> rescued:         0 B,  errsize:       0 B,  errors:       0
> Current status
> rescued:   250057 MB,  errsize:   1835 kB,  current rate:   48103 kB/s
>    ipos:   250059 MB,   errors:      49,    average rate:   34888 kB/s
>    opos:   250059 MB
> Not sure what to do next!  
> Should I remove the bad drive & reconnect the other 3 (including the old one) and try to reassemble the array???  Or, should I try to redo it without the old one connected?
> David Labens
> San Antonio, TX

To my knowledge "--no-split" means not to rescue anything.  But according to the log it would appear that 1825kb was rescued.  For good luck I would run the command again with error recovery turned on:

ddrescue --direct --max-retries=3 /dev/sdb /dev/sda logfile

And as you noticed the drive number assignments don't always follow the plug number.  Once all the drives are plugged back in it should go back to the way that it was.  Just check and make sure.

So went you first ran ddrescue, it copied the 80gb os drive onto the new 250gb new drive?  ddrescue keeps a log file of where it starts and stops reading at (I am guessing that would be resclog1?).  So if you copied 80gb of the os drive onto the new drive and then fixed the drive numbers, then that 250gb drive would have the first 80gb of it still from the os drive.  If you formatted the newdrive and then reran that command without first deleting (or renaming) resclog1, then it would started where it last left off. Meaning the first 80gb of the newdrive would have nothing on it? Did you ever delete the logfile?

If not I would recommend running it again just to be sure:

ddrescue --no-split /dev/oldDrive /dev/newDrive resclog2
and then:
ddrescue --direct --max-retries=3 /dev/oldDrive /dev/newDrive resclog2
-- _______________________________________________
SATLUG mailing list
SATLUG at satlug.org
http://alamo.satlug.org/mailman/listinfo/satlug to manage/unsubscribe
Powered by Rackspace (www.rackspace.com)

More information about the SATLUG mailing list