[SATLUG] RAID5 Recovery - ddrescue: copy completed!

Samuel Leon satlug at net153.net
Sun Aug 23 13:16:34 CDT 2009


David Labens wrote:
> Sam
> 
> Every time I ran ddrescue, I gave it a different logfile name.  BUT, I don't think it uses the LOGFILE to figure out it's starting & stopping point.  I say this because when I figured out what I did wrong, and reran the command using a new logfile name, it still started copying from 80 gb!  That's when I figured I'd go in with fdisk and delete the partition & save it then recreate the partition.  I tried to do it without saving it (just delete partition & then recreate partition), and it still started from the 80 gb point.  But, when I saved it between, it started copying from the first byte to the last.  So, I'm confident that it did copy the full 250 gb from the source drive.
> 
> Would running the command again cause it to do nothing because it already ran?  Wouldn't I need to delete the partition & start over?  Or does the change in the command parameter allow it to retry and repair in the process?
> 
> David Labens
> 

hmm, well if you are sure that it copied the data then I will have to 
take your word for it.

You could try: (note reusing same logfile)
ddrescue --direct --max-retries=3 /dev/sdb /dev/sda resclog1

just to make sure that it got all of the errors. If it truly is done 
then I guess it wouldn't do anything.

In the mean time I am going to build a small virtual raid5 set up in 
vmware and torture it some just to make sure I know what I am doing. 
Give me about an hour.

Sam


More information about the SATLUG mailing list