[SATLUG] Apple TV loading Linux & MythTV

Marc Ripley misteratomic at gmail.com
Fri Jan 2 14:28:03 CST 2009


Ok gang, I need your help if at all possible.

I was shopping SAMS Club on the 24th and they were clearing out Apple
TVs (ATV) for 113 bucks a piece.
Well, I snagged the last two they had with the hopes of hacking Linux
on it for a MythTV frontend.
I find that the hardware is capable of easily doing 1080i under the
nvidia proprietary driver and, of course, running Linux.

I am currently in the process of the hack which includes a USB boot
stick to telnet into the ATV to perform the hack.
I've followed the guide located at
http://www.mythtv.org/wiki/index.php/Installing_MythFrontend_on_Apple_TV_using_Gentoo.

Everything goes well including the repartitioning of the ATV and
un-tar of the gentoo files.

The project hits the skids when I attempt to enter the "New Environment":

mount -t proc none gentoo/proc

works fine, then...

mount -o bind /dev gentoo/dev

errors with an "invalid argument"

I've tried all sorts of syntax and researched the mount -o bind command.

I'm at a loss to know how to proceed.   I tried to move forward but
when I later got to:

emerge -v =gentoo-sources-2.6.24-r8 genkernel
this worked fine

but
genkernel --kernel-config=/usr/src/config-2.6.24.3 all
fails with unable to mount /dev/BOOT and more similar failures.  I'm
sure it's related to not being able to bind "/dev" with the mount
command.

Any hint to point me in the right direction?
I'm surprised I got as far as a telnet port on the ATV and formatting it!
-- 
Marc


More information about the SATLUG mailing list