[SATLUG] File system corruption

Alan Lesmerises alesmerises at satx.rr.com
Sat Jul 18 23:23:24 CDT 2009


A couple of weeks ago, I got an error message (from within KDE) saying 
the authentication system failed.  I tried to log onto my system via the 
CLI and got some I/O errors.  When I posted this issue to the group, 
Jeremy said it looked like the file system was corrupted and that I 
should use fsck to fix it.  It worked that time (BTW, thanks Jeremy), 
but now it seems to have happened again, and the problem is much worse now.

First, to recap, my system has 2 identical Seagate 400GB SATA drives 
configured as RAID 0, and I'm running OpenSUSE 11.1 x64.  I have 4 
partitions on each (Boot, Root, Swap, & user data files).

The first time around, fsck reported errors only on one partition, SDA7 
(the Root partition of the first drive).  The errors mainly consisted of 
"Inode xxxx has illegal block(s)", etc.  I used fsck to fix the errors, 
rebooted and repaired the OS files and I was back in business.  But 
after just a few days, my system crapped-out again, this time errors 
were reported on both the Root & data partitions of both drives.  The 
errors included "Illegal Blocks", "Multiply-claimed block(s) in inode 
xxxx" and dates being "in the future" (many of each kind of error on 
each partition).

So here are the questions I hope you can help me with:

1. What's going on with these errors?  What do those error messages mean?

2. Does anyone have any idea what could be causing these errors?

3. I've put extra cooling fans on the hard drives themselves, but I 
don't think that is really the problem.  It's extremely unlikely that 
both drives would be failing simultaneously, so could the motherboard be 
to blame?

TIA.

Al Lesmerises



More information about the SATLUG mailing list