[SATLUG] Fedora 11 and Yum

John Clements jclements at grandecom.net
Sat Jun 20 14:37:50 CDT 2009


Just updated from Fedora 10 to 11.  Yum worked in Fedora 10.
When typing 'yum' at the command line as root, get a message that says
'No module named yum'. Here's the steps taken, any hints greatly appreciated.

John Clements

Typed yum as root, following appeared

"There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

     No module named yum

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.6 (r26:66714, Mar 17 2009, 11:44:21)
[GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)]

If you cannot solve this problem yourself, please go to
the yum faq at:
    http://wiki.linux.duke.edu/YumFaq  "

YumFaq at question 7 states:

"If you are getting a message that yum itself is the missing module then
you probably installed it incorreclty (or installed the source rpm using
make/make install). If possible, find a prebuilt rpm that will work for
your system like one from Fedora or CentOS. Or, you can download the
srpm and do a

rpmbuild --rebuild yum*.src.rpm"

found yum-3.2.23-0.src.rpm via google and downloaded, then in the directory where
the yum*.src file is located, as root 'rpmbuild --rebuild yum*.src.rpm' per instructions above,
same result, get same error message.

Any hints?  really need yum for updates.

JCC





More information about the SATLUG mailing list