[SATLUG] Fedora 11 and Yum

Greg Swift gregswift at gmail.com
Sun Jun 21 18:54:06 CDT 2009


On Sat, Jun 20, 2009 at 14:37, John Clements <jclements at grandecom.net>wrote:

> Just updated from Fedora 10 to 11.  Yum worked in Fedora 10.


did you use preupgrade to do the upgrade from 10 to 11?  If not what method
did you use?


>
> When typing 'yum' at the command line as root, get a message that says
> 'No module named yum'. Here's the steps taken, any hints greatly
> appreciated.
>
> John Clements
>
> Typed yum as root, following appeared
>
> "There was a problem importing one of the Python modules
> required to run yum. The error leading to this problem was:
>
>    No module named yum
>
> Please install a package which provides this module, or
> verify that the module is installed correctly.
>
> It's possible that the above module doesn't match the
> current version of Python, which is:
> 2.6 (r26:66714, Mar 17 2009, 11:44:21)
> [GCC 4.4.0 20090313 (Red Hat 4.4.0-0.26)]
>
> If you cannot solve this problem yourself, please go to
> the yum faq at:
>   http://wiki.linux.duke.edu/YumFaq  "
>
> YumFaq at question 7 states:
>
> "If you are getting a message that yum itself is the missing module then
> you probably installed it incorreclty (or installed the source rpm using
> make/make install). If possible, find a prebuilt rpm that will work for
> your system like one from Fedora or CentOS. Or, you can download the
> srpm and do a
>
> rpmbuild --rebuild yum*.src.rpm"
>
> found yum-3.2.23-0.src.rpm via google and downloaded, then in the directory
> where
> the yum*.src file is located, as root 'rpmbuild --rebuild yum*.src.rpm' per
> instructions above,
> same result, get same error message.

After you ran this command, do you install the rpm it built?


>
> Any hints?  really need yum for updates.


For starters, if as long as you have RPM installed, you don't need to
re-build the yum packages, just use the existing.  What I would do is the
following steps.


Do the following:

# rpm -q yum
you should get something like this:
yum-3.2.22-4.fc11.noarch

If its not there, I would do download the good non-source RPM from one of
the mirrors (although the one you just built on your system should work as
well)

If it is there I would run this:
rpm --qaV yum

You'll probably see some missing files, you can either download the rpm
matching the version listed, or if there is a newer you can download that.
If you want to install the same version over what is there just do

rpm -ivh --force <file>

to upgrade just do:

rpm -Uvh <file>


More information about the SATLUG mailing list