[SATLUG] Fedora 11 and the RTL8169 network driver

David Salisbury david.salisbury at momentumweb.com
Mon Jun 22 15:24:40 CDT 2009


Wondering if anyone out there has been able to get an RTL8169-based NIC 
working in Fedora 11.  It's a gigabit NIC, and from all the googling 
I've done there's apparently some sort of issue kernel-wise that 
prevents the NIC from working "out-of-the-box".  But, basically, the 
card at first seems like it will work fine (ie, with a cable plugged in 
the lights on the card are both on, with one blinking as normal, when 
the machine is not on), but once Fedora boots the lights get shut off 
and only one of them blinks every now and again, and Fedora "sees" the 
card (ie, assigns it an eth0) but the media status is listed as 
"disconnected".

The issue is a apparently a Wake-On-LAN issue, according to all that 
I've read, and the problem has been solved by many people in a dual-boot 
environment
 by, oddly enough, setting some flags on the Windows side before a 
reboot and then booting into Fedora after that.  This has apparently 
worked for a lot of people.  Unfortunately, I'm not dual booting so I 
can't super-easily give it a shot.  I've tried a couple of tools to wake 
it up manually, ether-wake and ethtool (both with appropriate arguments 
/ MAC addy / etc), and neither of them seem to make a difference.

I CAN wake up a NIC on the machine I'm on, correct?  I don't think I 
have to be on another machine?  I would assume not.  Maybe I should try 
that.  Anyway, just wondering if anyone else had had this issue and 
maybe came upon a solution, even on another version of Fedora (or 
Linux-y OS)?

David



More information about the SATLUG mailing list