[SATLUG] server configuration

Enrique Sanchez esanchezvela.satlug at gmail.com
Tue Dec 28 13:17:24 CST 2010


On Tue, Dec 28, 2010 at 12:26 PM, Scott Coil <scott at chaos-dragon.com> wrote:
> On Tue, 28 Dec 2010 12:21:10 -0500
> Enrique Sanchez <esanchezvela.satlug at gmail.com> wrote:
>
>> I am having an issue with 2 different servers, these are SuSE 10sp3,
>> while they are supposed to be using the same configuration, I have a
>> different vi experience on each of them,
>>
>> on both servers I open the same file, yep, name and access bits are
>> the same, while on one I get the full experience of color coded syntax
>> highlights, on the other I don't, the process I use to access the
>> servers is a bit different, although I think it shouldn't matter.
>>
>> to access ServerA, I just use ssh to access it thru a socks server,
>> while to access ServerB, I first login to ServerA, then I use ssh to
>> access ServerB, while this could be the issue, there are other servers
>> in the environment that preserve the syntax highlighting to which of
>> them I still use ServerA as a jump server.
>>
>> I've checked, the TERM variable (same on both), :set all (same on
>> both) and the VIM level on both servers, checksum on .exrc is the same
>> for both. any more settings to check??
>>
>>
>> thanks,
>> esv.
>>
>>
>>
>
> Two places I can think to check are ~/.vimrc and /etc/vim/vimrc
>
> Scott
> --


thanks, but actually neither existed, however ran : strace vim

and realized vim was using /etc/vimrc which was different on each
host, probably had I checked the file list on each RPM and verified
their consistency, I would have spotted the difference faster/easier,
etc.

thanks again.
enrique.


More information about the SATLUG mailing list