[SATLUG] errors when building a qt program on my laptop

Bruce Dubbs bruce.dubbs at gmail.com
Fri Jan 15 17:56:38 CST 2010


John D Choate wrote:
> I have the same OS, Mandriva 2010.1(cooker), installed on both my
> desktop machine and my laptop. I also have basically the same
> packages installed on both and all updated. Let me first state that,
> yes, I do have libqt4-devel installed.!.! QT sources build properly
> on my desktop machine with no issues whatsoever. But on my laptop I
> get an error related to /usr/lib/qt4/include/QtCore/qlist.h

> There must be some other factor involved, but make is finding the
> qt4-devel files right where they are supposed to be. What could be
> the problem?

Do you have qt3 also installed on your laptop?

qmake -v

For me:

QMake version 2.01a
Using Qt version 4.5.2 in /opt/qt-4.5.2/lib

I have both and using qt3's version of qmake causes this type of problem 
with qt4 source.  I haven't played with cmake, so I can't help there.


   -- Bruce


More information about the SATLUG mailing list