[SATLUG] Re: Sound Issues

Robert Pearson e2eiod at gmail.com
Sun Jan 17 05:07:07 CST 2010


On Sat, Jan 16, 2010 at 7:14 PM, Michael <mmorse757 at gmail.com> wrote:
> Don Davis wrote:
>>
>>> KDE 3.5.10
>>
>> KDE uses the arts daemon which can be awkward. I haven't had problems with
>> it in a while.
>>
>> What does
>> artsshell status
>> tell you?
>>
>> You might want to check this out:
>>
>> http://linux.derkeiler.com/Newsgroups/comp.os.linux.misc/2006-12/msg00463.html
>> http://ubuntuforums.org/showthread.php?t=3999
>>
>>
>> If you want to kill sound with htop look for artsd.
>>
>> I would recommend scanning your xsession error logs and
>> installing/reinstalling alsa-utils.
>>
>>
> Thank you for the info.  I am going to save this message for later use.  I
> became to frustrated to play with it any longer, so I sent back to FF
> 2.0.0.23.  The only reason I changed to FF 3.* was because FF 2.* had issues
> with the Facebook website. However, Facebook is at the very bottom of my
> priorities/list of interests so going back to FF 2* was no big deal.
>
> I am sure that I (eventually) will have to switch back (notice I do NOT use
> the term 'upgrade') to 3.*  When I do, I'll have your reply to refer to.
>  Thanks again.
>
>
> --
> _______________________________________________
> SATLUG mailing list
> SATLUG at satlug.org
> http://alamo.satlug.org/mailman/listinfo/satlug to manage/unsubscribe
> Powered by Rackspace (www.rackspace.com)
>

Isn't this on a PCLinuxOS machine? Are you running 2009?
How did you do your upgrades?
It might be that some other packages need to be upgraded for FF 3.* to work.
On the other hand some packages may have been upgraded that conflict
with your audio chip.

I have 3 PCLinuxOS machines and none of them has had any problems with
FF and sound.
The newest machine has all kinds of sound problems with multimedia
like Flash and the video players on both Linux OS's. The problems are
identical in both Linux OS's.
The type of file seems to make more of a difference than the program playing it.
This machiine has a Realtek ALC662 rev1 (digital) chip and dual boots
Ubuntu 9.04 (previously 8.04, 8.10) and PCLinuxOS 2009. The sound does
not work right on that machine for any Linux OS but does work fine
with Windows. It has to do with the drivers. Linux is very late with
drivers. I was advised the fix is to either download ALSA source and
compile it all on the machine or buy a sound card for the PCI bus. I
don't wish to do either.

[Begin "Texstar" post]
"Texstar", the guy who builds and releases PClinuxOS has a post on the
Forum about how to do updates:
How to properly update PCLinuxOS.

Open Synaptic
Press Reload  To get current file list
Click Mark All Upgrades
CLick Apply

DO NOT USE apt-get update and apt-get upgrade from the command line.
This has never been recommended. If you insist on using the command
line, the correct procedure is apt-get update and apt-get
dist-upgrade.  If for any reason the system says it is not able to
retrieve a package do you wish to continue always say no, report it to
the forum and try to update again later.
<http://www.pclinuxos.com/forum/index.php/topic,63199.msg550062.html#new>
[End "Texstar post]

My personal experience has been a little different than what "Texstar" says.
I used Synaptic religiously with PCLinuxOS 2007 and never seemed to
have a problem for a long time.
Near the end of PCLinuxOS 2007 I started having update/upgrade
problems related to repositories. When I started using PCLinuxOS 2009
I had repository and upgrade/update problems. Just like I have had
with every Linux OS I have used starting with Red Hat. I stopped using
Fedora Core, openSUSE and even PCLinuxOS.

The problem for me was for some reason Synaptic didn't seem to
properly synchronize all the updates/upgrades with regard to
dependencies. I started using the sequence:

apt-get update ; apt-get dist-upgrade (just like "Texstar" mentioned
as an alternative)

I started using this sequence instead of Synaptic and still had
problems with repositories. I finally found a repository that was, and
still is, valid and reliable.
<ftp://ftp.ch.debian.org/mirror/pclinuxos/apt>.
With the "apt-get" sequence and the repository above I have had no
real update problems for a while.

I did have a problem recently with the "motion" program on PCLinuxOS
when they released an update linked to the wrong libraries. They
finally fixed it and released one that works. Interestingly enough I
never saw a word on the Forums or anywhere from a Google search about
the problem. My other machines run Ubuntu 9.04 and Mint Gloria.
"motion" worked fine on them during this whole time.

HTH, YMMV


More information about the SATLUG mailing list