[SATLUG] help! two very annoying firefox-related problems

David Kowis dkowis at shlrm.org
Thu Jul 29 15:01:23 CDT 2010


On 7/29/2010 1:28 PM, travis+ml-satlug at subspacefield.org wrote:
> Hey all,
> 
> I would REALLY appreciate it if you could help me with two very
> annoying firefox problems.
> 
> My setup: 64-bit Kubuntu.
> 
> Problem 0:
> 
> I installed foxyproxy recently, then uninstalled it, and now firefox
> will start, but not actually do anything:
> 
> $ ps -efw | grep firefox
> user       2963  2827  0 11:13 ?        00:00:01 /usr/lib/firefox-3.5.9/firefox --sm-config-prefix /firefox-4d48mQ/ --sm-client-id 10[............................]058 --screen 0
> user       3049  2827  0 11:14 ?        00:00:01 /usr/lib/firefox-3.5.9/firefox
> 
> That has been that way for a half hour.
> 
> I think I had this problem with FoxyProxy once before.
> 
> How in the world do I troubleshoot this?  Last time I had this problem
> I ended up having to create a new profile dir, re-import my bookmarks,
> I lost all my browser-saved passwords (fortunately I have them saved
> in a pw manager), and I had to reinstall all my plugins.
> 
> Problem 1:
> 
> I tried out torbutton lately, and it didn't work.  Specifically, every
> time I test the proxy settings, it either doesn't work or fails, and
> it has some very weird behavior (like connecting to port 8118 instead
> of 8123 for polipo).  There seems to be a new proxy dialog box that
> makes some weird assumptions.  And if you start torbutton without a
> successful test, it simply doesn't use tor.
> 
> I thought it might just be my machine's configuration, so I installed
> torbutton on my netbook, a lucid lynx install, and it exhibits the same
> behavior there too.
> 
> Looking at tcpdump, I do see successful connections to polipo, and I
> see it issuing 'CONNECT' HTTP command with some kind of
> torbutton-related destination, but I don't see any obvious errors.
> For some reason tcpdump -X seems to not show the whole HTTP request
> and response - it's like it's partially compressed or SSL or
> something.
> 
> I would really appreciate any help on these, I don't quite know where to
> start discussing this, and my browser's dead :-(
> 


Quickfix: Blow away your profile directory ~/.mozilla (Or move it to
keep the important things around. You can then copy over your bookmarks,
it's in the directory structure somewhere)

That will get you a working browser. Not sure about the torbutton stuff,
or the foxyproxy. I"ve used foxyproxy before, and it worked well for me.
But that was a source based distro and it was a long time ago now.

David


More information about the SATLUG mailing list