[SATLUG] PHP IDE

Richard Suberg rsuberg at satx.rr.com
Tue Feb 8 16:56:29 CST 2011


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256
 
Ok time for a quick lesson I found out....I missed a line on the php
script.  Dang program didn't think for me... :D
I forgot the line
    $row = mssql_fetch_array($result);
after the line
    $result = mssql_query($query)
so I had the result from the sql query, but hadn't put it in the $row
array I was trying to use...oops....

On 2/8/2011 3:14 PM, Richard Suberg wrote:
>
> I have done that also, and I don't see a problem with the sql
> statement. Also, the sql search is not returning false, so I see it
> is succeeding but not returning any results....strange because I
> am searching on the primary key value.
>
> On 2/8/2011 2:36 PM, Charles Hogan wrote:
>> What I do when I run into similar problems, is echo the sql
>> statement that is to be run onto the screen as well. This gives
>> me the opportunity to examine the statement for errors.
>
>
>
>> On 02/08/2011 02:24 PM, Richard Suberg wrote:
>>>
>> I need some help on a php script. I am actually looking for an
>> IDE for PHP that will allow me to step through the script to find
>> out exactly what is going wrong. This script is connecting to an
>> MS SQL server database to pull data and redisplay it. If I were
>> to run the SQL statement in Access, I get the data I want, but if
>> I put the same SQL statement straight into the PHP script it
>> fails (I assume the entire statement is too long) so I decided to
>> break it up into separate SQL statements. The first one runs ok,
>> store results in several arrays, (as proven with an echo $array[]
>> loop) and then free the sql result (mssql_free_result) but any
>> further sql queries I run with the data from the array as a part
>> of the where clause in SQL comes up empty. Is anyone familiar
>> with this or has an IDE for php that will allow stepping through
>> the script to find out what is going on? The fun part is the
>> server that is hosting the php site is Ubuntu, but developing the
>> php file on WinXP, so an IDE for either environment would be
>> good. I've tried Eclipse, but it says it can't find the php
>> binary on the windows machine (likely because the php would never
>> install correctly on this computer)
>
>>>
>

- -- 
Thunderbird Portable...it goes with me!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/
 
iF4EAREIAAYFAk1Ryh0ACgkQNZUTANkBj/6uggD+OtDdKSSXVYrfQFvgzrIb3Hk2
VzqESJc227twf9ig44QA/RlWioYVYMf2DondKqgt7vfBMZcHCJ0LEg1aSt/o97WG
=FrWN
-----END PGP SIGNATURE-----



More information about the SATLUG mailing list