[SATLUG] Monitor res in Ubuntu 10.04

hc at lookcee.com hc at lookcee.com
Sun Jan 9 10:39:50 CST 2011


HC;

I did a google search over badname and xrandr to see if anyone else had a
similar situation and came across this:

http://stackoverflow.com/questions/851704/xrandr-errors-badname-named-color-or-font-does-not-exist

Some people had success using a different name such as "1080i" instead of
"1280x768". From the looks of your xrandr output, you already do have a
resolution mode named 1280x768, so this might be the problem.

In another instance, the settings were already programmed and he just had to
-addmode and --output. Might be good to check around to see if anything
follows your situation exactly.



Heh, got it, thanks James.

I assumed then that the term "1280x1024_60" was a placeholder (or sumpin of that nature) and there must already be one and since the command was not as root it refused to replace it so I tried this

xrandr --newmode "1024P"  138.75  1280 1368 1504 1728  1024 1027 1034 1072 -HSync +Vsync
xrandr --addmode VGA1 "1024P"
xrandr --output VGA1 --mode "1024P"


it worked but still overflowed the screen. So I restarted x and since others were using that res at 60hz I decided to use that as:

xrandr --newmode "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
xrandr --addmode VGA1 "1280x1024_60.00"
xrandr --output VGA1 --mode "1280x1024_60.00"

I entered the commands one at a time and it worked super so now I have the screen centered proper and at the correct res.... I then went to Sys/Prefs/Monitor and the setting was showing in the choices. where before it was not. I clicked apply and I have not rebooted so dunno yet if that 'apply' set it permanent or not.

I have some work to do first, I saw a post on how to do this. So I will attempt it later and report but looks like the glitch somehow got resolved, no clue why it did not work at first.
Thanks for the help
herb





More information about the SATLUG mailing list