[SATLUG] NFS super slow on Debian

Alex Bartonek bartonekdragracing at yahoo.com
Mon Nov 28 22:35:36 CST 2011


(This is a copy-n-paste from a forum I put this issue on.  Hopefully its legible on the ML).

I'm having an odd problem.

I have FreeNAS 8.0.2 release i386 installed on a PowerEdge SC440 with an 80GB drive setup for FreeNAS and 320GB setup for NFS.

I have the NFS share mounted on my Debian Linux (latest.."Squeeze")  box as:


192.168.1.11:/mnt/StorageA/themagicm on /media/StorageA type nfs (rw,nodev,addr=192.168.1.11)

nfsstat -mount shows:


root at debianlaptop:/home/themagicm# nfsstat -mount
/media/StorageA from 192.168.1.11:/mnt/StorageA/themagicm

Flags: 
 rw,nodev,relatime,vers=3,rsize=32768,wsize=32768,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.11,mountvers=3,mountport=924,mountproto=udp,addr=192.168.1.11


On the server (FreeNAS.. the share is "async" enabled).

/etc/exports looks like:

/mnt/StorageA/themagicm -alldirs -mapall=themagicm:nasgrp


When
I copy a 2.2GB file from the Linux box the first 500-600MB flys through
at about 30mb sec, then slows down, 29, 28, 27, 26 and so on,
decrementing down to, oh I dunno, 1mb...crawling.

So I get my wife's Macbook and do a plain jane mount..

mount 192.168.1.11:/mnt/StorageA/themagicm x


I do a "cp bigassfile.tar.gz x/."... it works NO PROBLEM.

I'm
stumped. I even tried making sure "udp" was the protocol in my mount,
but that didnt solve it. (yes I realize in my code entry above it shows
"tcp".. I tried both)

I dont have any errors in dmesg.   I've tried this on openSuSE 11.4, 12.1 to see if it was a distro quirk..but it wasnt.


Thanks in advance...


More information about the SATLUG mailing list