[SATLUG] Just for fun...

Bruce Dubbs bruce.dubbs at gmail.com
Thu Sep 29 09:39:51 CDT 2011


Howard Haradon wrote:
> On Wed, Sep 28, 2011 at 8:12 PM, Bruce Dubbs <bruce.dubbs at gmail.com> wrote:
>> Well, yes, it's a binary executable in that directory, or you can build it
>> from the source if you want.
>>
>>  -- Bruce
> 
> I chmoded it to be executable and ran it in a terminal, but here
> is the error that I received:
> ./mandelbrot: symbol lookup error:
> ./mandelbrot: undefined symbol: _ZN11QVectorData8allocateEii
> 
> This is under Xubuntu 8.04 with the latest patches and a bunch of
> libqt4 stuff installed.

Thanks Howard.  What do you get when you do:

ldd ./mandelbrot

For me, I get:

$ ldd ./mandelbrot
         linux-gate.so.1 =>  (0xffffe000)
         libQtGui.so.4 => /opt/qt-4.7.0/lib/libQtGui.so.4 (0xb7450000)
         libQtCore.so.4 => /opt/qt-4.7.0/lib/libQtCore.so.4 (0xb7199000)
         libpthread.so.0 => /lib/libpthread.so.0 (0xb716e000)
         libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0xb7092000)
         libm.so.6 => /lib/libm.so.6 (0xb706d000)
         libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0xb7062000)
         libc.so.6 => /lib/libc.so.6 (0xb6f40000)
         libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xb6f3b000)
         librt.so.1 => /lib/librt.so.1 (0xb6f32000)
         libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xb6e7e000)
         libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb6e57000)
         libz.so.1 => /lib/libz.so.1 (0xb6e43000)
         libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb6dd2000)
         libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xb6d95000)
         libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xb6d8c000)
         libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xb6d74000)
         libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0xb6d6c000)
         libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb6d42000)
         libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0xb6d33000)
         libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xb6c69000)
         libdl.so.2 => /lib/libdl.so.2 (0xb6c65000)
         /lib/ld-linux.so.2 (0xb7f85000)
         libpcre.so.0 => /usr/lib/libpcre.so.0 (0xb6c35000)
         libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb6c15000)

I suspect a mismatch in the Qt versions.

   -- Bruce


More information about the SATLUG mailing list