[SATLUG] Can't Play a Netflix Blu-Ray Disc in VLC Media Player

Jeff Barnette jeffrey.barnette at comcast.net
Sat Apr 6 10:55:51 CDT 2013


I got a new Blu-Ray writer/player yesterday, put in one of my BD discs and tried to play it in VLC Media Player Got an error 
related to a missing AACS library and certificate set. I looked the error up online and got instructions for resolving it. No problem so far. 

I then put in a Netflix BD and tried to play that. VLC reported that I don't have the AACS key for that disc. I tried again with another Netflix BD and got the same error. Apparently, the KEYDB.cfg (key database) file I'm using is out of date. After repeated web searches, I was unable to find an updated one. I went online and found multiple Linux users having the same issue while trying to play BDs, but with no solution. 

One site made a statement that "BD+ is another Blu-ray protection scheme and VLC cannot play such discs." One of the VLC developers (Jean-Baptiste Kempf) said "The BD+ issue is not solvable yet. But for AACS, it should just work. " 

Does Netflix tend to use BD+ protection on their discs? Is anyone able to view Blu-Ray discs using VLC on Linux? 

For now, I've gotten around the problem by using WinDVD on my Win7 box, but this is obviously not ideal. 

Thanks for any help, 
Jeff 



More information about the SATLUG mailing list