[SATLUG] GRUB @ RAID

dikov dikov dikov1 at yahoo.com
Sat Oct 12 20:36:30 CDT 2013


Hi
There is an Centos 6 installation with two HDDs in LSI RAID1 array. /boot is on separate partition 1 and rest (/) on LVM. After yum update with new kernel the boot process stopped at grub with error 13. Here I was asked to help. I tried to install grub into MBR of the RAID1 disk manually. I booted from rescue live CD and from chroot tried to 

#grub-install   /dev/mapper/ddf1_XXXXXX (i.. to MBR of RAID)

but got error that there is corresponding BIOS drive. I spent a lot of time in grub  console no luck. With soft RAID I should install into MBR of every disk like 

grub> setup (hd0)
but this did not work here.

Finally, I followed "install or upgrade" in live CD menu and was able to restore grub without reinstalling OS. In that wizard I selected to install GRUB in MBR of the RAID drive i.e. ddf1_XXXX and it worked.
So my question is what the magic going on with grub and hard RAID? 
best,
Dmytro


More information about the SATLUG mailing list