[SATLUG] GRUB @ RAID

Daniel Wallace danielwallace at gtmanfred.com
Sat Oct 12 23:08:24 CDT 2013



> Date: Sat, 12 Oct 2013 18:36:30 -0700
> From: dikov1 at yahoo.com
> To: satlug at satlug.org
> Subject: [SATLUG] GRUB @ RAID
> 
> Hi
> There is an Centos 6 installation with two HDDs in LSI RAID1 array. /boot is on separate partition 1 and rest (/) on LVM. After yum update with new kernel the boot process stopped at grub with error 13. Here I was asked to help. I tried to install grub into MBR of the RAID1 disk manually. I booted from rescue live CD and from chroot tried to 
> 
> #grub-install   /dev/mapper/ddf1_XXXXXX (i.. to MBR of RAID)
> 
> but got error that there is corresponding BIOS drive. I spent a lot of time in grub  console no luck. With soft RAID I should install into MBR of every disk like 
> 
> grub> setup (hd0)
> but this did not work here.
> 
> Finally, I followed "install or upgrade" in live CD menu and was able to restore grub without reinstalling OS. In that wizard I selected to install GRUB in MBR of the RAID drive i.e. ddf1_XXXX and it worked.
> So my question is what the magic going on with grub and hard RAID? 
> best,
> Dmytro
> 
> -- 
> _______________________________________________
> SATLUG mailing list
> SATLUG at satlug.org
> http://alamo.satlug.org/mailman/listinfo/satlug to manage/unsubscribe
> Powered by Rackspace (www.rackspace.com)

did you remember to set your

grub> root (hd0,0) before running setup (hd0) ? you also may need to set device (hd0) /dev/mapper/ddf1_XXXX  before anything else

or if you don't want to set device, you can should be able to find what to set root to with

grub> find /grub/stage1

- Daniel
 		 	   		  


More information about the SATLUG mailing list