[SATLUG] floppy issue

Borries Demeler demeler at biochem.uthscsa.edu
Sun Apr 12 05:57:46 CDT 2015


On Sun, Apr 12, 2015 at 02:27:22AM -0500, Craig wrote:
> Have you tried:
> sudo modprobe floppy

 udisks --mount /dev/fd0
Mount failed: Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/fd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

dmesg | tail:

[46572.884710] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884798] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884799] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884801] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884802] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884804] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884805] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884835] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.884836] AMD-Vi: Event logged [IO_PAGE_FAULT device=00:14.0 domain=0x000f address=0x000000000008c3f0 flags=0x0020]
[46572.885170] EXT2-fs (fd0): error: can't find an ext2 filesystem on dev fd0.

Trying to put a ext2 or msdos or vfat file system onto the drive fails also every time.

-b.
> and then
> udisks --mount /dev/fd0
> 
> On Sun, Apr 12, 2015 at 1:46 AM, Craig <sargonemail at gmail.com> wrote:
> 
> > Borries Demeler demeler at biochem.uthscsa.edu on Sat Apr 11 17:25:57 CDT
> > 2015 wrote:
> > > Finally got back to this.
> > > Here is what I find:
> > >
> > > * I can boot an old dos/windows95 floppy from the drive just fine
> > ..
> > > * mounting the old or newly formatted floppies under Linux is impossible:
> >   ...
> > >
> > > * formatting the floppies under Linux with any filesystem seems to
> > succeed at
> > > first, including all Linux or windows or msdos file systems, at least
> > there is
> > > no error message.
> > >
> > > * mounting such formatted filesystems under Linux returns the same exact
> > error
> > > as above:
> >   ...
> > >
> > > Any idea?
> > ...
> >
> > It sounds like the floppy controller for /dev/fd0 is not associated with
> > the traditional floppy controller (could be ata, ide/eide, pata, usb, scsi,
> > etc)
> > In not totally correct technical terms, need to figure out first which
> > bus/controller /dev/fd0 is being associated with.
> > (e.g. hard drive bus example: ata, ide, eide, scsi, usb.
> >  Tools for each are different, so just saying /dev/harddrive would NOT
> > indicate if ata, ide, eide, scsi or usb hard drive tools/modules are
> > needed!)
> > e.g. fdutils will not work with a usb floppy!
> > The output of the command: floppy -p
> > would provide appropriate information to figure out what's going on.
> >
> > Craig
> >
> >
> -- 
> _______________________________________________
> SATLUG mailing list
> SATLUG at satlug.org
> http://alamo.satlug.org/mailman/listinfo/satlug to manage/unsubscribe
> Powered by Rackspace (www.rackspace.com)


More information about the SATLUG mailing list