[SATLUG] floppy issue

Craig sargonemail at gmail.com
Sun Apr 12 08:59:45 CDT 2015


> On Sun, Apr 12, 2015 at 02:27:22AM -0500, Craig wrote:
> >* Have you tried:
*>>* sudo modprobe floppy
*>
> udisks --mount /dev/fd0
> Mount failed: Error mounting: mount: wrong fs type, bad option, bad superblock on /dev/fd0,
...

After doing *"sudo modprobe floppy"*, what does dmesg show?
(or going for same effect, different method, is "floppy" listed in
/etc/modules -- if not add & reboot)
*> THe floppy drive is hooked to a traditional motherboard floppy controller
*> with the flat ribbon cable connector (slightly shorter than a PATA
connector).
....

Yes, unfortunately the days where the floppy on the software side
could exclusively look at the 8 bit fdc/isa bus and/or
expect at most 2 floppies on a system are long gone.  The software
side, the motherboard floppy controller is not limited
to keeping the the floppy on the 8 bit fdc/isa bus.
Since the device directory is populated with /dev/fd0 when a floppy
device is detected and the command "sudo modprobe floppy"
doesn't generate a "No such device" message; it would seem there are
other things to look at.

For me, the first thing would be to figure out if what was the legacy
fdc was remapped to && subsequently, which different floppy
tools are needed to match the associated "bus change". e.g. floppy can
be mapped to /dev/idr and/or /dev/sdr in which case the traditional,
standard floppy tools will not function and give the results/error
messages that have been posted.

"floppy -p" was historically a quick way to do this.
Side note: I use embedded linux -- so tend to use historical command sets.

udisk --show-info /dev/fd0 may help.
The following may be helpful in showing the remapping of /dev/fd0.
udisks --enumerate
udisks --enumerate-device-files

There are other things to check out, given there are mainstream
distros that have dropped floppy support and/or automatically
block floppy access.
Knowing the distro/version would be helpful.
Knowing the specific motherboard model number would be helpful.


On Sun, Apr 12, 2015 at 2:27 AM, Craig <sargonemail at gmail.com> wrote:

> Have you tried:
> sudo modprobe floppy
> and then
> udisks --mount /dev/fd0
>
> On Sun, Apr 12, 2015 at 1:46 AM, Craig <sargonemail at gmail.com> wrote:
>
>> Borries Demeler demeler at biochem.uthscsa.edu on Sat Apr 11 17:25:57
>> CDT 2015 wrote:
>> > Finally got back to this.
>> > Here is what I find:
>> >
>> > * I can boot an old dos/windows95 floppy from the drive just fine
>> ..
>> > * mounting the old or newly formatted floppies under Linux is
>> impossible:
>>   ...
>> >
>> > * formatting the floppies under Linux with any filesystem seems to
>> succeed at
>> > first, including all Linux or windows or msdos file systems, at least
>> there is
>> > no error message.
>> >
>> > * mounting such formatted filesystems under Linux returns the same
>> exact error
>> > as above:
>>   ...
>> >
>> > Any idea?
>> ...
>>
>> It sounds like the floppy controller for /dev/fd0 is not associated with
>> the traditional floppy controller (could be ata, ide/eide, pata, usb, scsi,
>> etc)
>> In not totally correct technical terms, need to figure out first which
>> bus/controller /dev/fd0 is being associated with.
>> (e.g. hard drive bus example: ata, ide, eide, scsi, usb.
>>  Tools for each are different, so just saying /dev/harddrive would NOT
>> indicate if ata, ide, eide, scsi or usb hard drive tools/modules are
>> needed!)
>> e.g. fdutils will not work with a usb floppy!
>> The output of the command: floppy -p
>> would provide appropriate information to figure out what's going on.
>>
>> Craig
>>
>>
>


More information about the SATLUG mailing list