[SATLUG] USB question

Mark Mayfield mayfield_mark at gvtc.com
Thu Aug 6 09:21:16 CDT 2015


I have not had great experiences with USB 3 in Linux. My experience has 
been sometimes things work, sometimes they don't. Sometimes a device 
will work in a usb 3 port and sometimes I have to plug it into a usb 2. 
Don't think I've seen that particular dmesg out though.

On 08/05/2015 08:56 PM, Bruce Dubbs wrote:
> I was working with a Logitech QuickCam Pro 4000 today.  I have several 
> USB ports on my system and I plugged it into one of the blue 
> connectors because it is supposed to be USB 3.0 and faster than the 
> USB 2.0 standard.
>
> The camera didn't work.  dmesg said:
>
> usb 2-1.1: cannot submit urb 0, error -28: not enough bandwidth
> usb 2-1.2: cannot submit urb 0, error -28: not enough bandwidth
> pwc: isoc_init() submit_urb 0 failed with error -28
>
> After playing around a while, I tried plugging the camera into a black 
> port which is supposed to be USB 2.0 and everything worked.
>
> Is there a compatibility issue for some devices that will not work 
> with USB 3.0?
>
>   -- Bruce



More information about the SATLUG mailing list